Sep 072012
 

Due to LaunchPad Bug #900620, and Debian Bug 650204, the PHP package was modified in both Debian and Ubuntu (for PHP versions 5.4.0 and newer) to have php5-fpm listen on a UNIX socket by default, running at /var/run/php5-fpm.sock.

This had a “NEWS” item in debian/NEWS, but was very obscure, and not extremely recent,so this change went by semi-stealthily.

Anyone upgrading to Quantal from Precise or earlier which have servers using php5-fpm assuming that it’ll continue to listen on 127.0.0.1:9000 will need to change their configurations to adapt for this change!

For NGINX, just change your fastcgi_pass lines to fastcgi_pass unix:/var/fpm/phpfpm.sock;.

This only applies to PHP and NGINX in Ubuntu 12.10 and later! It does NOT apply to Ubuntu 12.04!